CVE-2026-56746: Netty has a Security Control Bypass via CORS Short-Circuit Failure
Telemetry drift only. No threshold crossed and no authority ruling changed.
CVE record, CISA KEV and EPSS as of 2026-10-18.
CVEs like this one computed, by meaning
What to do now held facts and links
- Upgrade to the fixed version for your release line, or later: netty 4.1.136; netty 4.2.16 upper bounds of the CVE record's affected ranges
- Later advisories still cover the fixes above and name higher ones: netty-codec-http 4.2.17.Final (CVE-2026-59903) OSV advisories
- Record your decision, dated and frozen with today's evidence: patch by a date · mitigated by a compensating control · deferred · accepted the risk · not affected
- Check your version against the ranges this record publishes.
What it is stated by the CNA
Netty is a network application framework for development of protocol servers and clients. Versions 4.2.0.Final through 4.2.15.Final and 4.1.0.Final through 4.1.135.Final, are vulnerable to security control bypass during the origin evaluation process. CorsHandler provides a shortCircuit() configuration designed to reject unauthorized cross-origin requests immediately, acting as a security control before requests reach the application. However, due to a logical operator error in the origin evaluation process, this protection can be entirely bypassed. An attacker can bypass the short-circuit mechanism by sending a request with an Origin: null header. This failure forwards unauthorized requests to the backend application, bypassing intended access controls. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.
- weakness
- CWE-284: Improper Access Control
- affected
- netty
- published ranges
- netty >= 4.1.0 < 4.1.136; netty >= 4.2.0 < 4.2.16
- first unaffected version, by branch
- netty 4.1.136; netty 4.2.16
- fixed by package (from OSV advisories)
- io.netty:netty-codec-http (Maven): 4.1.136.Final; 4.2.16.Final GHSA-6cqp-g7gg-8hr5
- later fixes (from OSV advisories)
- netty-codec-http 4.1.136.Final is inside a range CVE-2026-59903 (GHSA-8c42-7qj2-3j46) lists as affected. That advisory is fixed in 4.1.137.Final.netty-codec-http 4.2.16.Final is inside a range CVE-2026-59903 (GHSA-8c42-7qj2-3j46) lists as affected. That advisory is fixed in 4.2.17.Final.
- severity
- 6.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- assigned by
- GitHub_M
- published
- 2026-07-21
check us github.com github.com github.com
Exploit code held, dated
- exploit code
- None held in the PoC-in-GitHub feed. A public repository changes this brief.
What moved held, dated
| date | EPSS | event |
|---|---|---|
| 22 Jul 2026 | 0.00478 | |
| 24 Jul 2026 | 0.00432 | |
| 31 Jul 2026 | 0.00369 | |
| 6 Aug 2026 | 0.00379 | |
| 28 Sep 2026 | 0.00408 |
5 observations held. A step marked with a scoring model moved because the measurement was replaced, not because the vulnerability changed.
Outside the record researched, cited
This section reads the record's references and adds cited findings from outside it. It needs an account. Everything above is held facts and is complete without it.
What would change this brief held, dated
- CISA KEV
- Not listed in the catalogue we hold. A listing changes this brief.
- exploit probability
- 0.00 on 2026-09-28 (FIRST's EPSS, a probability and not evidence of exploitation). Next band line: 10% (0.10). Crossing a line changes this brief.
- fix
- Held: netty 4.1.136; netty 4.2.16. A newer fix from the CNA or OSV changes this brief.
How to check this
Every value above is held with two dates: when it was true upstream (as_of) and when we recorded it (tx_from). Re-derive the exploit probability as it stood on any date:
SELECT value, source, source_version, as_of, tx_from
FROM volatile_valid_as_of('CVE-2026-56746', '2026-10-31T23:59:59.999999Z', now());