CVE-2022-34255: Adobe Commerce Improper Access Control Privilege escalation
Telemetry drift only. No threshold crossed and no authority ruling changed.
CVE record, CISA KEV and EPSS as of 2026-10-18.
CVEs like this one computed, by meaning
What to do now held facts and links
- Upgrade to the fixed version for your release line, or later: commerce 2.3.7; commerce 2.4.3; magento 2.3.7; magento 2.4.3 upper bounds of the CVE record's affected ranges
- Later advisories still cover the fixes above and name higher ones: magento 2.4.3 (CVE-2021-28566), 2.4.3 (CVE-2021-28567), 2.4.4-p11 (CVE-2024-45124), 2.4.4-p11 (CVE-2024-45125), 2.4.4-p11 (CVE-2024-45127), 2.4.4-p11 (CVE-2024-45128), 2.4.4-p11 (CVE-2024-45129), 2.4.4-p11 (CVE-2024-45130), 2.4.4-p11 (CVE-2024-45131), 2.4.4-p11 (CVE-2024-45132), 2.4.4-p11 (CVE-2024-45133), 2.4.4-p11 (CVE-2024-45134), 2.4.4-p11 (CVE-2024-45135), 2.4.4-p11 (CVE-2024-45148), 2.4.4-p11 (CVE-2024-45149), 2.4.5 (CVE-2022-42344) OSV advisories
- Record your decision, dated and frozen with today's evidence: patch by a date · mitigated by a compensating control · deferred · accepted the risk · not affected
- Check your version against the ranges this record publishes.
What it is stated by the CNA
Adobe Commerce versions 2.4.3-p2 (and earlier), 2.3.7-p3 (and earlier) and 2.4.4 (and earlier) are affected by an Improper Access Control vulnerability that could result in Privilege escalation. An attacker with a low privilege account could leverage this vulnerability to perform an account takeover for a victim. Exploitation of this issue does not require user interaction.
- weakness
- CWE-284 Improper Access Control (CWE-284)
- affected
- Adobe Magento Commerce
- published ranges
- adobe commerce >= 2.3.0 < 2.3.7; adobe commerce >= 2.4.0 < 2.4.3; adobe commerce 2.3.7; adobe commerce 2.3.7-p1; and 16 more on the CVE page
- first unaffected version, by branch
- commerce 2.3.7; commerce 2.4.3; magento 2.3.7; magento 2.4.3
- fixed by package (from OSV advisories)
- magento (Bitnami): 2.3.7; 2.4.3 BIT-magento-2022-34255magento/community-edition (Packagist): 2.3.7-p4; 2.4.3-p3; 2.4.5 GHSA-x95x-f4g9-mm85
- later fixes (from OSV advisories)
- magento 2.3.7 is inside a range CVE-2021-28566 (BIT-magento-2021-28566) lists as affected. That advisory is fixed in 2.4.3.magento 2.3.7 is inside a range CVE-2021-28567 (BIT-magento-2021-28567) lists as affected. That advisory is fixed in 2.4.3.magento 2.3.7 is inside a range CVE-2024-45124 (BIT-magento-2024-45124) lists as affected. That advisory is fixed in 2.4.4-p11.magento 2.3.7 is inside a range CVE-2024-45125 (BIT-magento-2024-45125) lists as affected. That advisory is fixed in 2.4.4-p11.magento 2.3.7 is inside a range CVE-2024-45127 (BIT-magento-2024-45127) lists as affected. That advisory is fixed in 2.4.4-p11.magento 2.3.7 is inside a range CVE-2024-45128 (BIT-magento-2024-45128) lists as affected. That advisory is fixed in 2.4.4-p11.
- severity
- 8.8 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- assigned by
- adobe
- published
- 2022-08-16
check us helpx.adobe.com
Exploit code held, dated
- exploit code
- None held in the PoC-in-GitHub feed. A public repository changes this brief.
What moved held, dated
| date | EPSS | event |
|---|---|---|
| 17 Aug 2022 | 0.00885 | |
| 19 Aug 2022 | 0.01046 | |
| 7 Mar 2023 | 0.00061 | scoring model v2023.03.01 |
| 8 Mar 2023 | 0.00061 | |
| 17 Mar 2025 | 0.00479 | scoring model v2025.03.14 |
| 15 Jun 2026 | 0.01702 | scoring model v2026.06.15 |
| 13 Aug 2026 | 0.01936 | |
| 2 Sep 2026 | 0.01949 | |
| 4 Sep 2026 | 0.02244 | |
| 12 Oct 2026 | 0.02293 |
27 observations held. A step marked with a scoring model moved because the measurement was replaced, not because the vulnerability changed.
Outside the record researched, cited
This section reads the record's references and adds cited findings from outside it. It needs an account. Everything above is held facts and is complete without it.
What would change this brief held, dated
- CISA KEV
- Not listed in the catalogue we hold. A listing changes this brief.
- exploit probability
- 0.02 on 2026-10-12 (FIRST's EPSS, a probability and not evidence of exploitation). Next band line: 10% (0.10). Crossing a line changes this brief.
- fix
- Held: commerce 2.3.7; commerce 2.4.3; magento 2.3.7; magento 2.4.3. A newer fix from the CNA or OSV changes this brief.
How to check this
Every value above is held with two dates: when it was true upstream (as_of) and when we recorded it (tx_from). Re-derive the exploit probability as it stood on any date:
SELECT value, source, source_version, as_of, tx_from
FROM volatile_valid_as_of('CVE-2022-34255', '2026-11-01T23:59:59.999999Z', now());