CVE-2017-16897
Telemetry drift only. No threshold crossed and no authority ruling changed.
CVE record, CISA KEV and EPSS as of 2026-10-18.
CVEs like this one computed, by meaning
What to do now held facts and links
- Upgrade to passport-wsfed-saml2 3.0.5 or later upper bounds of the CVE record's affected ranges
- Later advisories still cover the fixes above and name higher ones: passport-wsfed-saml2 4.6.3 (CVE-2022-23505), 4.6.4 (CVE-2025-46572), 4.6.4 (CVE-2025-46573) OSV advisories
- Record your decision, dated and frozen with today's evidence: patch by a date · mitigated by a compensating control · deferred · accepted the risk · not affected
- Check your version against the ranges this record publishes.
What it is stated by the CNA
A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).
- weakness
- Not named by the CNA. NVD maps it to CWE-290.
- affected
- Not named by the CNA. The published ranges name Auth0 passport-wsfed-saml2.
- published ranges
- auth0 passport-wsfed-saml2 < 3.0.5
- first unaffected version, by branch
- passport-wsfed-saml2 3.0.5
- fixed by package (from OSV advisories)
- passport-wsfed-saml2 (npm): 3.0.5 GHSA-77fw-rf4v-vfp9
- later fixes (from OSV advisories)
- passport-wsfed-saml2 3.0.5 is inside a range CVE-2022-23505 (GHSA-ppjq-qxhx-m25f) lists as affected. That advisory is fixed in 4.6.3.passport-wsfed-saml2 3.0.5 is inside a range CVE-2025-46572 (GHSA-wjmp-wphq-jvqf) lists as affected. That advisory is fixed in 4.6.4.passport-wsfed-saml2 3.0.5 is inside a range CVE-2025-46573 (GHSA-8gqj-226h-gm8r) lists as affected. That advisory is fixed in 4.6.4.
- assigned by
- mitre
- published
- 2017-12-23
check us auth0.com
Exploit code held, dated
- exploit code
- None held in the PoC-in-GitHub feed. A public repository changes this brief.
What moved held, dated
| date | EPSS | event |
|---|---|---|
| 14 Apr 2021 | 0.00416 | |
| 4 Feb 2022 | 0.00885 | |
| 7 Mar 2023 | 0.00222 | scoring model v2023.03.01 |
| 4 Sep 2024 | 0.00245 | |
| 17 Mar 2025 | 0.00445 | scoring model v2025.03.14 |
| 29 Mar 2025 | 0.00928 | |
| 30 Mar 2025 | 0.00445 | |
| 9 Jul 2025 | 0.00422 | |
| 15 Jun 2026 | 0.01138 | scoring model v2026.06.15 |
| 22 Jun 2026 | 0.01378 | |
| 23 Aug 2026 | 0.01504 | |
| 30 Aug 2026 | 0.01378 | |
| 5 Sep 2026 | 0.01504 | |
| 6 Sep 2026 | 0.01378 |
14 observations held. A step marked with a scoring model moved because the measurement was replaced, not because the vulnerability changed.
Outside the record researched, cited
This section reads the record's references and adds cited findings from outside it. It needs an account. Everything above is held facts and is complete without it.
What would change this brief held, dated
- CISA KEV
- Not listed in the catalogue we hold. A listing changes this brief.
- exploit probability
- 0.01 on 2026-09-06 (FIRST's EPSS, a probability and not evidence of exploitation). Next band line: 10% (0.10). Crossing a line changes this brief.
- fix
- Held: passport-wsfed-saml2 3.0.5. A newer fix from the CNA or OSV changes this brief.
How to check this
Every value above is held with two dates: when it was true upstream (as_of) and when we recorded it (tx_from). Re-derive the exploit probability as it stood on any date:
SELECT value, source, source_version, as_of, tx_from
FROM volatile_valid_as_of('CVE-2017-16897', '2026-11-01T23:59:59.999999Z', now());